Jun 27, 2012

(XCode) How to have lower simulator in Xcode 4.3 of Lion

The Xcode 4.3 does not have simulator other than 5.1 and 4.3, but sometimes we need to test apps on the lower environement. So here is the trick: You need have lower Xcode installation files, and copy the simulator folders to the Xcode 4.3.

 For exemple:
sudo mv /XCode file/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.1.sdk/ /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/

No comments: